Is the the pump or something else


Joined
Nov 19, 2020
Messages
2
Reaction score
1
Country
United Kingdom
I have a positive head pump which has worked fine for ages ( on a system that in truth needs a universal pump ).
Historically - I turn on the shower with the shower head low down - the pump then kicks in - then I raise the shower head and it has always worked consistently for the shower for as long as needed.

Now this no longer works and the shower and pump will actually come on at a low level but wont stay on and as i raise it after 30 seconds the pump cuts so. However, If I also turn on the hot water tap on the nearby sink , it works consistently throughout the showering.

I took off the shower push pump hoses to see if anything was blocking within the filters but this has changed nothing.

Is this basically a knackered pump or something else?

Thank so much.
 
Ad

Advertisements

Joined
Nov 19, 2020
Messages
2
Reaction score
1
Country
United Kingdom
I think I have solved it. i changed over the showerhead in the summer for one of the marvellous ones with the ceramic balls in that make the shower pressure better. Tonight - i just thought what of i change it back and now it works again.
 
Ad

Advertisements

Joined
Sep 15, 2018
Messages
424
Reaction score
237
Location
South Manchester
I think I have solved it. i changed over the showerhead in the summer for one of the marvellous ones with the ceramic balls in that make the shower pressure better. Tonight - i just thought what of i change it back and now it works again.

Well done.

Ity's the same with our Triton, it "doesn't like" any head other than the one with which it is supplied. But in this case it's the resistance of the head that affects the level of electrical power.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top