Honeywell CM927?


Joined
Oct 7, 2018
Messages
3
Reaction score
0
Hi guys.
New to forum.
I've recently moved into a new home 8 months ago (well not brand new),
There's Vailant Ecotec plus in the upstairs landing cupboard. which has been fine until now.
I can't get the heating to come on. The water is fine.
I think it might be something to do with the CM927 or the BDR91 relay box .
Have changed the batteries in the CM927, no joy.
No lights on the BDR91, tried pressing the button for 5 secs etc, still no luck.
Any help would be very much appreciated.

As you might've guessed, I'm not too familiar with wireless control's. :D
 
Joined
Oct 7, 2018
Messages
3
Reaction score
0
Not sure if anyone has looked at my post, but I went ahead and purchased a new CM927 & BDR91 kit.
I know!!! taking a chance.
I managed to install them.
The rely box was a bugger to fit though, wired up correctly, and the front of the box just wouldn't go onto the backplate easily :( Typical of Honeywell to make things difficult.
anyway, got it on eventually, but now have a steady flashing RED light on the bottom neon, and a steady GREEN one on the top neon.
Have looked through the manual, but couldn't see a paragraph on this. Does say about re-binding Though.
It can't be that surely being new set, could it?
Help please?
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top