immersion heater fault or economy heater fault


B

bigbadbade

Can anyone help on this one. During a complete bathroom fit-out (this
is where the hot water cylinder lives) - a new copper cylinder was
fitted complete with a 3kw Resettable Long Life Immersion Heater 27"
incalloy type from Screwfix (part no 63692). After commisioning the
system all systems OK so it was time to test the Immersion Heater,
which is run off an Economy 7 Horstmann Timer (old model - probably 20
years old - of the current Screwfix part 44419) and the original supply
cable. Due to the time of day the 1 hour boost control was used to test
element heating. Result after that time - YIPPEE HOT WATER.

Next morning run hot taps - NO hot water after the timed system should
have cut-in. Due to having back-up water heating from the solid fuel
back boiler another test was not undertaken for a couple of days.
Re-test time on boost again, this no hot water. Isolated supply and
checked supply connections to Immersion Heater - removed all
connections and cut back all wires to make new fresh connections and
reattached to terminals. Next removed front panel of timer to check
connections - all good no breaks/loose wiring. Reconnect supply and
test - power lights on (ON) RED at the timer but still no hot water.

Any Ideas? - bearing in mind the timer and hot water system has been
out of commission for about 4 months - my thoughts are the timer as its
old and maybe the initial power-up and run finished off the supply feed
to IH cable.
OR is there something I need to reset on the IH - If so what and how.

I deperately do not want to change the IH out of the tank as I would
need to remove the tank from it's location due to lack of headroom.
 
Ad

Advertisements

T

Tim Lamb

In message <[email protected]>,
bigbadbade said:
OR is there something I need to reset on the IH - If so what and how.
Dave had a cut-out problem. On the only one I have seen, there is a tiny
square hole in the face of the thermostat. Isolate the circuit and give
it a poke.
I deperately do not want to change the IH out of the tank as I would
need to remove the tank from it's location due to lack of headroom.
There is a neat hole in the loft floor directly above ours:)

regards
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top