Combi Boiler Ravenheat CSI 85A

Discussion in 'UK DIY' started by oscosc@gmail.com, Oct 17, 2008.

  1. Guest

    Hi,

    I'm passing this request along for a friend, so please forgive any
    ignorance or mistakes on my part. The problem is with a Ravenheat CSI
    85A combi boiler... it won't light (duh!).

    The unit was self-installed, and has worked without problems for the
    last few years. A week or so ago, the unit would no longer light
    reliably. Turning on the hot water tap became a pot luck affair. If
    you left it running for 20-30m, you might get hot water eventually. A
    visual inspection of the boiler during this time showed the boiler
    lighting for a few seconds, but then turning off again. It would, on
    occasion, decide to light properly and deliver hot water untill the
    tap was turned off again.

    Since then the problem has gotten worse. Now the fan works, but the
    pilot light will not light and the pump will not run. The fan only
    works intermittently though.. it will come on for a few minutes and
    then turn off for a few minutes.

    The ignition board has been replaced, but it made no difference.

    Does anyone have any advice on what may be wrong?

    Thanks in advance.
    , Oct 17, 2008
    #1
  2. A.Lee Guest

    <> wrote:

    > I'm passing this request along for a friend, so please forgive any
    > ignorance or mistakes on my part. The problem is with a Ravenheat CSI
    > 85A combi boiler... it won't light (duh!).

    .............
    > Since then the problem has gotten worse. Now the fan works, but the
    > pilot light will not light and the pump will not run.


    So the pilot light will not light?
    It is the pilot light that lights the main gas burner, so it sounds like
    a pilot fault.
    Screwfix, and most decent plumbers merchants (I've seen them in B+Q too)
    sell a universal pilot light thermocouple kit for around £5.
    When my pilot wouldnt stay alight, I changed the thermocouple, and all
    was fine again.
    Alan.

    --
    To reply by e-mail, change the ' + ' to 'plus'.
    A.Lee, Oct 18, 2008
    #2
  3. chudford Guest

    On Oct 17, 9:58 pm, wrote:
    > Hi,
    >
    > I'm passing this request along for a friend, so please forgive any
    > ignorance or mistakes on my part. The problem is with a Ravenheat CSI
    > 85A combi boiler... it won't light (duh!).
    >
    > The unit was self-installed, and has worked without problems for the
    > last few years. A week or so ago, the unit would no longer light
    > reliably. Turning on the hot water tap became a pot luck affair. If
    > you left it running for 20-30m, you might get hot water eventually. A
    > visual inspection of the boiler during this time showed the boiler
    > lighting for a few seconds, but then turning off again. It would, on
    > occasion, decide to light properly and deliver hot water untill the
    > tap was turned off again.
    >
    > Since then the problem has gotten worse. Now the fan works, but the
    > pilot light will not light and the pump will not run. The fan only
    > works intermittently though.. it will come on for a few minutes and
    > then turn off for a few minutes.
    >
    > The ignition board has been replaced, but it made no difference.
    >
    > Does anyone have any advice on what may be wrong?
    >
    > Thanks in advance.


    I had a similar problem with my son's Ravenheat boiler.

    Ravenheat have a good website with manuals for their boilers and fault
    finding charts.

    When the fan starts a sensor detects that there is a pressure
    difference between the flue and the boiler.

    Two possible faults here 1. The sensor is not working or its tubes are
    blocked or leaking: or 2. The boiler casing is not properly sealed (in
    my son's case the casing seal round the flue had come loose)

    If the pressure sensor is working then you should hear the igniter
    clicking. If it clicks but the pilot does not light, then there is a
    problem with the gas circuit and I suggest you get in a professional.

    If there is no clicking then change the igniter spark plug and check
    the lead to the plug.

    Hope this helps a bit.
    chudford, Oct 18, 2008
    #3
  4. geoff Guest

    In message <1iozx1v.1x822i5kbokj6N%alan@darkroom.+.com>, A.Lee
    <alan@darkroom.+.com> writes
    ><> wrote:
    >
    >> I'm passing this request along for a friend, so please forgive any
    >> ignorance or mistakes on my part. The problem is with a Ravenheat CSI
    >> 85A combi boiler... it won't light (duh!).

    >............
    >> Since then the problem has gotten worse. Now the fan works, but the
    >> pilot light will not light and the pump will not run.

    >
    >So the pilot light will not light?
    >It is the pilot light that lights the main gas burner, so it sounds like
    >a pilot fault.
    >Screwfix, and most decent plumbers merchants (I've seen them in B+Q too)
    >sell a universal pilot light thermocouple kit for around £5.
    >When my pilot wouldnt stay alight, I changed the thermocouple, and all
    >was fine again.


    The CSI 85A is a condensing boiler with electronic ignition

    The reply above (for a pp boiler) is completely wrong

    The problem could lie anywhere from not sensing the fan through a faulty
    pcb to a valve solenoid

    The description is so vague that it isn't really possible to make more
    of a diagnosis - get a man in


    --
    geoff
    geoff, Oct 18, 2008
    #4

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. mlegdon
    Replies:
    2
    Views:
    744
    mlegdon
    Feb 5, 2006
  2. Keith D

    Ravenheat CSI 85 story

    Keith D, Feb 23, 2006, in forum: UK DIY
    Replies:
    2
    Views:
    289
    Ed Sirett
    Feb 24, 2006
  3. osc
    Replies:
    0
    Views:
    545
  4. citizen142

    Ravenheat CSI 85

    citizen142, Mar 23, 2006, in forum: UK Home Improvement
    Replies:
    1
    Views:
    191
  5. Adrian C

    Ravenheat CSI 85T failure to spark.

    Adrian C, Jun 2, 2011, in forum: UK DIY
    Replies:
    7
    Views:
    476
    geoff
    Jun 4, 2011
Loading...

Share This Page