CH and HW problem

Discussion in 'UK DIY' started by Russell, Aug 19, 2003.

  1. Russell

    Russell Guest

    My system has gone bananas. I have a Potterton Kingfisher 2 boiler,
    which fires up for about a minute, with higher than normal flue gas
    teperatures. The pump does not run unless I push the motorised valve
    (2 port) round with a screwdriver to operate the microswitch. Can
    anyone tell me where to start checking for the fault? When the pump is
    running it makes a sound like the water is cavitating within if that
    gives any clues.

    Thanks
     
    Russell, Aug 19, 2003
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. dave
    Replies:
    9
    Views:
    699
  2. Fleemo

    Furnace Kicks On and Off and On and...

    Fleemo, Nov 21, 2004, in forum: Home Repair
    Replies:
    15
    Views:
    271
    Steve@carolinabreezehvac
    Nov 25, 2004
  3. Arthur Davis
    Replies:
    1
    Views:
    479
    Ross Mac
    Jan 9, 2005
  4. Wilfred Xavier Pickles

    Volts and AC's and DC's and Gar. Door Opener

    Wilfred Xavier Pickles, Jun 13, 2009, in forum: Misc DIY
    Replies:
    11
    Views:
    508
  5. Al Barnhard

    Chicken-and-Egg Problem: Whirlpool Deck Tile and Faucets

    Al Barnhard, Nov 2, 2003, in forum: Building Construction
    Replies:
    4
    Views:
    224
    Eric Ryder
    Nov 3, 2003
Loading...

Share This Page